WordPress

升級WordPress所使用的PHP版本

隨著WordPress版本不斷地更新,它所使用的PHP版本要求也愈來愈高。在筆者編寫本篇文章時PHP的版本已經來到了8.1版,因此如果你的WordPress網站是在很久之前就裝好的,很有可能後來你登入之後,會發現如下所示的說明,提醒需要升級你的PHP版本。

如果你的WordPress是透過cPanel等介面安裝,可以輕易地在主機控制台介面中可以找到切換PHP版本的功能。但是,如果你使用的是Ubuntu作業系統利用命令列的方式安裝的話,那麼就需要先找出你的系統中是否有安裝新的PHP版本,如下:

# locate /bin/php
/usr/bin/php
/usr/bin/php7.2
/usr/bin/php7.4
/usr/bin/php8.1

上述的例子表示在系統中安裝了3種PHP的版本。如果沒有找到7.4以上的版本,那麼就需要去安裝這個版本才行。但是系統安裝了2種以上的版本並不表示你的Apache伺服器使用的是哪個版本,在本例,儘管系統上有3種版本,但目前Apache2使用的卻是7.2版,此時,就需要使用以下的方式先把7.2版本disable,然後enable新的7.4版,指令如下:

a2dismod php7.2
a2enmod php7.4

然後還要安裝php7.4版本所需要的相關模組,至少mysql模組要更新一下:

apt install php7.4-mysql

最後再重啟apache2系統就可以了:

service apache2 restart

當然,如果想要改進WordPress的執行效率的話,在Performance的說明中,列出來的每一個模組都可以安裝一下:

安裝的方法如下:

apt install php7.4-curl php7.4-dom php7.4-imagick php7.4-mbstring php7.4-zip php7.4-intl php7.4-gd

安裝完畢之後,別忘了再把apache2重啟動之後才會生效。

發表迴響

在下方填入你的資料或按右方圖示以社群網站登入:

WordPress.com 標誌

您的留言將使用 WordPress.com 帳號。 登出 /  變更 )

Twitter picture

您的留言將使用 Twitter 帳號。 登出 /  變更 )

Facebook照片

您的留言將使用 Facebook 帳號。 登出 /  變更 )

連結到 %s